How to stop a System process from listening on port 80 to allow Apache to run?

$0
=
$0.2
+
$0
No specific Bitcoin Bounty has been announced by author. Still, anyone could send Bitcoin Tips to those who provide a good answer.
0

I cannot start apache2 server because some other process is blocking port 80. From the Netstat I have learned that it is a System process who has a socket open to port 80 with an IP address of 0.0.0.0. This does not help much. What exactly in System process is listening on the port 80? How do I stop System process from using port 80? What the hell is IP address 0.0.0.0?

Any thoughts?

enter image description here

2 answers - total earned - 0 BTC ($0 USD)

2
=
0
=
$0
Everyone, even non-registered users could send Bitcoin Tips to YOU if they are inspired by your answer!

I think it may be SQL Server Reporting Services (SQLEXPRESS) that comes with MS SQL Server 2012.

To disable that service, follow these steps:

  1. Control Panel -> Administrative Tools -> Computer Manager -> Services
  2. enter image description here

Then please try starting apache2 and see if the problem is still there. It helped solving this problem in my case.


SEND BITCOIN TIPS
0

As I understand you use Windows as OS and IIS as web server. So seems IIS uses this port.

Try to stop IIS and run Apache.

SEND BITCOIN TIPS
0

Post Answer


Will Bitcoin Tipping become a new Internet Culture?


Please share our story! THANK YOU!